Исправление "Видов доходов НДФЛ" при обновлении БП 3.0, ЗУП 3.1, КА 2.*

Публикация № 1581309 07.01.22

Бухгалтерский учет - Зарплата

доход ндфл

В топике https://forum.infostart.ru/forum86/topic274909/ "уже существует вид дохода НДФЛ" описана ошибка при обновлении. У меня было несколько баз разных конфигураций с такой же ошибкой - решил внешними обработками, написал в теме как, но решил упростить жизнь кому-нить, если очень нужно.

08.01.22 Версия 1.1 Исправлена ошибка в определении правильных элементов - спасибо RomaM - на его базе тренировались и совещались.
09.01.22 Версия 1.3 Изменил поиск элементов для замены, проверяется предопределенность, если предопределённых в дубле больше одного - элемент будет отвязан. Спасибо нашедшему ошибку Fraktalov.
10.01.22 Версия 1.5 Ещё раз изменил определение "правильных" элементов, спасибо user932790  за базу для теста.
11.01.22 Версия 1.6 Ещё раз изменил определение "правильных" элементов...

Порядок использования по пунктам вывел в картинках.

Если всё проходит нормально - то увидим предупреждение "Обработка завершена...", жмём Закрыть и Перезапустить - должно обновиться...

В обработке использовал функцию замены ссылок из обработки "Поиск и замена дублирующихся элементов справочников" отсюда же, к сожалению не помню автора, и в обработке нет информации. Большое ему спасибо. 

Важно - для теста использовал БП 3.0 ДЕМО, в которой принудительно создал дубли в справочнике (команда создания в этой же обработке есть, просто убрал видимость, если кому то интересно поиграться - можете включить в конфигураторе).

Если на боевых базах будут ошибки - пишите в комментариях, или в личку - могу подключиться и посмотреть, что происходит...

Тестировалось на платформе 8.3.20.1674, при обновлении БП 3.0 с 3.0.105.45 на 3.0.106.60.

Вариант процедуры подготовки замены для скачавших версии от 1.3 - замените на этот код:

&НаСервереБезКонтекста
Процедура ЗаменитьНаБольшие(СтрокиГруппы, ПустаяТаблица)
	
	Оставить = ПустаяТаблица.Скопировать();
	СтрокаОставить = Оставить.Добавить();
	Заменить = ПустаяТаблица.Скопировать();
	//Первый проход = проверяем, есть предопределнный  элемент(ы)
	ЕстьПредопределнный = Ложь;
	Для Каждого стр Из СтрокиГруппы Цикл
		Если стр.Ссылка.Предопределенный Тогда
			ЕстьПредопределнный = Истина;
			ЗаполнитьЗначенияСвойств(СтрокаОставить, стр);
		КонецЕсли;
		Если Не ЕстьПредопределнный Тогда 
			ОтвязатьПредопреденность(стр.Ссылка);
			ДобавитьСтрокуВТаблицу(Заменить, стр);
		КонецЕсли;
	КонецЦикла;
	//Создаем пустую таблицу, заполняем из массива дублей, сортируем по убыванию количества ссылок и заполняем что оставить, а что хаменить, блин
	Если НЕ ЕстьПредопределнный Тогда
		Оставить = ПустаяТаблица.Скопировать();
		Заменить = ПустаяТаблица.Скопировать();
		ИсхТаб   = ПустаяТаблица.Скопировать();
		Для Каждого стр Из СтрокиГруппы Цикл
			НовСтр = ИсхТаб.Добавить();
			ЗаполнитьЗначенияСвойств(НовСтр, стр);
		КонецЦикла;
		ИсхТаб.Сортировать("Количество Убыв");
		Сч = 0;
		Для Каждого стр Из ИсхТаб Цикл
			Сч = Сч + 1;
			Если Сч = 1 Тогда
				НовСтр = Оставить.Добавить();
			Иначе
				НовСтр = Заменить.Добавить();//исправил, в выложенной ранее версии тут была ошибка
			КонецЕсли;
			ЗаполнитьЗначенияСвойств(НовСтр, стр);
		КонецЦикла;
	КонецЕсли;
	Если Оставить.Количество() = 1 и Заменить.Количество() <> 0 Тогда
		//Всё нормально
		МассивКУдалению = Заменить.ВыгрузитьКолонку("Ссылка");
		Получилось = ВыполнитьЗаменуЭлементовНаСервере(СтрокаОставить.Ссылка, МассивКУдалению);
		Если Получилось Тогда 
			Для Каждого стр Из МассивКУдалению Цикл
				СпрОбъект = стр.ПолучитьОбъект();
				СпрОбъект.Удалить();
			КонецЦикла;
		КонецЕсли; 
	Иначе
		Сообщить("Не удалось определить ""правильный"" элемент справочника! Исправление не прошло...");
	КонецЕсли;
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Исправить виды доходов НДФЛ

.epf 10,12Kb
224
.epf 1.6 10,12Kb 224 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. burgomister 41 07.01.22 16:18 Сейчас в теме
Была такая проблема. Решил снятием с поддержки, удалением элемента справочника, потом обновил и поставил на поддержку. Если ваша обработка помогает решить проблему без этого, замечательно.
user683648_ganiman68; Alex_E; +2 Ответить
2. Alex_E 2255 07.01.22 17:36 Сейчас в теме
(1) Уже подтвердили в https://forum.infostart.ru/forum86/topic274909/, выходит, что работает)))
3. inferna_666 07.01.22 21:20 Сейчас в теме
Отличная обработка, исправила проблему обновления на 3.0.106.60. Автору огромное спасибо!
rosinfo1; user932790; Alex_E; +3 Ответить
4. Alex_E 2255 07.01.22 22:14 Сейчас в теме
61. dakork 25 22.01.22 19:45 Сейчас в теме
(3) Сработало нормально на ЗУП КОРП 3.1.18.337
5. SoftLeon 26 08.01.22 10:53 Сейчас в теме
Предопределенные элементы обработка исправила, обычные - нет. Пришлось брать в руки напильник
6. Alex_E 2255 08.01.22 15:21 Сейчас в теме
(5) Что для Вас есть предопределенные элементы и в чём их отличие от обычных? Сразу выскажу своё понимание вопроса - предопределённые элементы - это те, что прописаны в конфигураторе, и в форме списка справочника помечены жёлтым шариком...исправить их моя обработка не могла в принципе, потому как она непосредственно удаляет дубли, которые вычислились как "лишние", а преопределённый элемент удалить не так то просто, и обработка не нём упала бы по ошибке. Возможна ситуация, когда ссылок на обычные элемент справочника было больше чем на предопределённый, тогда не отработало - была попытка удалить предопределённый...

В любом случае, если помогла - отрадно, а что напильник понадобился, так напишите в чём - поправлю. Обработка написана на коленке, по просьбам трудящихся, все мои базы, в которых был этот косяк я поправил без неё (другими обработками, не заточенными именно под этот случай), потому в ней вполне могут быть косяки, про которые не подумалось)))
7. alexey_t 08.01.22 16:45 Сейчас в теме
Обработка не помогает, всё равно ошибка: Уже существует вид дохода ндфл с таким значением поля Код (2012)
8. Alex_E 2255 08.01.22 20:52 Сейчас в теме
(7) Как раз такая ситуация (2012) была у RomaM,порешали - работает в новой версии. Пишите в личку - могу на почту сбросить, чтобы убедиться, что у всех работает...
9. Fraktalov 09.01.22 11:13 Сейчас в теме
Здравствуйте, поймал эту ошибку при обновлении БП. Очень бы выручила Ваша обработка, но к сожалению нет абонемента(
10. user932790 09.01.22 11:37 Сейчас в теме
11. Fraktalov 09.01.22 11:45 Сейчас в теме
1С:Предприятие 8.3 (8.3.18.1741)
Бухгалтерия предприятия, редакция 3.0 (3.0.106.60)

Помогло, автору большое спасибо!!!
12. user932790 10.01.22 09:40 Сейчас в теме
А как получить новую версию? Сейчас попробовал еще на одной базе, после обработки, ошибка осталась
13. Vladisa 37 10.01.22 10:49 Сейчас в теме
запустил клиент ваше обработку, что-то она уже час работает...так нужно?
14. Alex_E 2255 10.01.22 11:17 Сейчас в теме
(13) Возможно, но ОЧЕНЬ маловероятно. Посмотреть бы отладчиком, что там происходит. Есть такая возможность?
15. Vladisa 37 10.01.22 12:07 Сейчас в теме
16. Alex_E 2255 10.01.22 14:24 Сейчас в теме
Люди!!! Если у кого произойдёт зависание на продолжительное время обработки, ПОЖАЛУЙСТА, дайте возможность посмотреть отладчиком, чтобы исправить ошибку. Она не на всех базах проявляется, мне проверить не на чем((((
17. Alex_E 2255 10.01.22 18:55 Сейчас в теме
Выложил новую версию 1.5
Дико извиняюсь за режим ошпаренной кошки (куяккуяк и в продакш) - просто обработка востребована, а как надо не протестирована, пытаюсь добить до нормального вида...

Изменил процедуру (вот новый вариант):
&НаСервереБезКонтекста
Процедура ЗаменитьНаБольшие(СтрокиГруппы, ПустаяТаблица)
	
	Оставить = ПустаяТаблица.Скопировать();
	СтрокаОставить = Оставить.Добавить();
	Заменить = ПустаяТаблица.Скопировать();
	//Первый проход = проверяем, есть предопределнный  элемент(ы)
	ЕстьПредопределнный = Ложь;
	Для Каждого стр Из СтрокиГруппы Цикл
		Если стр.Ссылка.Предопределенный Тогда
			ЕстьПредопределнный = Истина;
			ЗаполнитьЗначенияСвойств(СтрокаОставить, стр);
		КонецЕсли;
		Если Не ЕстьПредопределнный Тогда 
			ОтвязатьПредопреденность(стр.Ссылка);
			ДобавитьСтрокуВТаблицу(Заменить, стр);
		КонецЕсли;
	КонецЦикла;
	//Если предопределенных нет - ищем по наибольшему количеству вхождений, 
	//если количество вхождений будет одинаково - правильным будет первый по порядку дубль
	//если количнество вхождение = 0 у всех дублей - правильным будет последний
	Если НЕ ЕстьПредопределнный Тогда
	    Заменить = ПустаяТаблица.Скопировать();
		Количество = 0; Счетчик = 0; КолСтрок = СтрокиГруппы.Количество(); ЕстьОставить = Ложь; БольшеНеИскать = Ложь;
		Для Каждого стр Из СтрокиГруппы Цикл
			Счетчик = Счетчик + 1;
			Если стр.Количество > Количество Тогда
				Если ЕстьОставить Тогда //Надо переписсать строку оставить в удаляемые
					ДобавитьСтрокуВТаблицу(Заменить, СтрокаОставить);
				КонецЕсли;
				ЗаполнитьЗначенияСвойств(СтрокаОставить, стр);
				ЕстьОставить = Истина; 
				Количество = стр.Количество;
			ИначеЕсли Счетчик < КолСтрок Тогда
				ДобавитьСтрокуВТаблицу(Заменить, стр);
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
	МассивКУдалению = Заменить.ВыгрузитьКолонку("Ссылка");
	Получилось = ВыполнитьЗаменуЭлементовНаСервере(СтрокаОставить.Ссылка, МассивКУдалению);
	Если Получилось Тогда 
		Для Каждого стр Из МассивКУдалению Цикл
			СпрОбъект = стр.ПолучитьОбъект();
			СпрОбъект.Удалить();
		КонецЦикла;
	КонецЕсли; 
	
КонецПроцедуры
Показать


Кто скачал версию 1.3 замените эту процедуру в модуле формы - будет как в 1.5
18. buriansergey 10.01.22 23:50 Сейчас в теме
Обработка не помогает, всё равно ошибка: Уже существует вид дохода ндфл с таким значением поля Код (2012)
19. Alex_E 2255 11.01.22 06:23 Сейчас в теме
Версия 1.6
&НаСервереБезКонтекста
Процедура ЗаменитьНаБольшие(СтрокиГруппы, ПустаяТаблица)
	
	Оставить = ПустаяТаблица.Скопировать();
	СтрокаОставить = Оставить.Добавить();
	Заменить = ПустаяТаблица.Скопировать();
	//Первый проход = проверяем, есть предопределнный  элемент(ы)
	ЕстьПредопределнный = Ложь;
	Для Каждого стр Из СтрокиГруппы Цикл
		Если стр.Ссылка.Предопределенный Тогда
			ЕстьПредопределнный = Истина;
			ЗаполнитьЗначенияСвойств(СтрокаОставить, стр);
		КонецЕсли;
		Если Не ЕстьПредопределнный Тогда 
			ОтвязатьПредопреденность(стр.Ссылка);
			ДобавитьСтрокуВТаблицу(Заменить, стр);
		КонецЕсли;
	КонецЦикла;
	//Создаем пустую таблицу, заполняем из массива дублей, сортируем по убыванию количества ссылок и заполняем что оставить, а что заменить, блин
	Если НЕ ЕстьПредопределнный Тогда
		Оставить = ПустаяТаблица.Скопировать();
		Заменить = ПустаяТаблица.Скопировать();
		ИсхТаб   = ПустаяТаблица.Скопировать();
		Для Каждого стр Из СтрокиГруппы Цикл
			НовСтр = ИсхТаб.Добавить();
			ЗаполнитьЗначенияСвойств(НовСтр, стр);
		КонецЦикла;
		ИсхТаб.Сортировать("Количество Убыв");
		Сч = 0;
		Для Каждого стр Из ИсхТаб Цикл
			Сч = Сч + 1;
			Если Сч = 1 Тогда
				НовСтр = Оставить.Добавить();
			Иначе
				НовСтр.Заменить.Добавить();
			КонецЕсли;
			ЗаполнитьЗначенияСвойств(НовСтр, стр);
		КонецЦикла;
	КонецЕсли;
	Если Оставить.Количество() = 1 и Заменить.Количество() <> 0 Тогда
		//Всё нормально
		МассивКУдалению = Заменить.ВыгрузитьКолонку("Ссылка");
		Получилось = ВыполнитьЗаменуЭлементовНаСервере(СтрокаОставить.Ссылка, МассивКУдалению);
		Если Получилось Тогда 
			Для Каждого стр Из МассивКУдалению Цикл
				СпрОбъект = стр.ПолучитьОбъект();
				СпрОбъект.Удалить();
			КонецЦикла;
		КонецЕсли; 
	Иначе
		Сообщить("Не удалось определить ""правильный"" элемент справочника! Исправление не прошло...");
	КонецЕсли;
КонецПроцедуры
Показать
20. Alex_E 2255 11.01.22 06:27 Сейчас в теме
Кстати, обработку можно использовать "превентивно" - ДО ОБНОВЛЕНИЯ. Если дубли есть, то они появились не в результате обновления, а уже сидят в базе. Поэтому если исходная (до обновления) копия есть, можно запустить обработку на ней (тут хоть отладка сработает), а потом обновлять, это так, к слову пришлось...
21. buriansergey 11.01.22 08:55 Сейчас в теме
Для "превентивного" удаления есть стандартная обработка Удаление дублей.
22. Alex_E 2255 11.01.22 09:41 Сейчас в теме
(21) Вы будете смеяться, но я в курсе...а вот есть люди, что не знают что есть и не знают как пользоваться...но написал я не для этого - если запустить менно эту обработку до обновления - то она будет отлаживаться напрямую, что гораздо удобнее, если хочется в этой обработке что то поменять...
23. пользователь 11.01.22 10:07
Сообщение было скрыто модератором.
...
24. Alex_E 2255 11.01.22 10:57 Сейчас в теме
1.6 поправил ошибку
//Было
//НовСтр.Заменить.Добавить();// - строка с ошибкой версии 1.6 
НовСтр = Заменить.Добавить();//исправил, в выложенной ранее версии тут была ошибка
Pechenka_Zero; +1 Ответить
25. Pechenka_Zero 11.01.22 10:58 Сейчас в теме
При нажатии "исправить" пишет: "метод объекта не обнаружен ( ) "
До обновления тоже пробовал, не помогло
26. Alex_E 2255 11.01.22 11:00 Сейчас в теме
(25) см (24) - ошибка в строке 474 модуля формы, см в личку
Pechenka_Zero; +1 Ответить
27. Doomino 53 11.01.22 13:37 Сейчас в теме
28. maraton86 11.01.22 13:40 Сейчас в теме
Все отлично отработало. Спасибо!
29. пользователь 11.01.22 22:41
Сообщение было скрыто модератором.
...
30. DenisSDG 12.01.22 10:54 Сейчас в теме
Вот такая ошибка:

Поле объекта не обнаружено (Заменить)
{ВнешняяОбработка.ИсправитьВидыДоходовНДФЛ.Форма.Форма.Форма(474)}:НовСтр.Заменить.Добавить();
{ВнешняяОбработка.ИсправитьВидыДоходовНДФЛ.Форма.Форма.Форма(539)}:ЗаменитьНаБольшие(СтрокиГруппы, ПустаяТаблица);
{ВнешняяОбработка.ИсправитьВидыДоходовНДФЛ.Форма.Форма.Форма(546)}:ИсправитьНаСервере();
31. Alex_E 2255 12.01.22 10:59 Сейчас в теме
Доброго времени суток!. Посмотрите пожалуйста в конфигураторе в модуле формы строку 474, там какой текст? в (24) описана эта ошибка, и она исправлена в выложенной версии 1.6 (по край мере я был в этом уверен), если это не так - замените строку на правильную и попробуйте ещё раз.

Отпишитесь, если не сложно, что получилось, если есть трудностьи - могу посмотреть по удаленке - пишите в личку.
32. user1689137 12.01.22 12:11 Сейчас в теме
Всем доброго дня.
Столкнулся с этой же проблемой, помогло следующее: при обновлении предварительно заходим в режиме Предприятия.

Администрирование - Обслуживание - Корректировка данных - Удаление дублей - далее выбираем искать в "Виды доходов НДФЛ", ищём и удаляем все дубли.
Затем идём в Обслуживание - сверху ссылка "Удаление помеченных объектов", удаляем вышеназванное.

Всё, проблем более после обновления не возникло. Всем удачи!
33. Alex_E 2255 12.01.22 12:39 Сейчас в теме
(32) Никто ж не спорит, что так можно, и уже обговаривалось и тут и в исходной ветке неоднократно)))
Обработка нужна тем, у кого нет времени на восстановление копии (или, что печальнее, нет той самой копии) или же база
34. Tigriss 12.01.22 14:25 Сейчас в теме
Огромное спасибо автору. Вчера потестила на 2х базах перед обновлением.
В предыстории обновляли БУХню, база словила ошибку. Не запускалась ни в конфигуратор ни в клиентское приложение.
Откатили на старую версию, копией. Сначала прогнали обработку. Потом запускали ТИИ после этого обновляем. Полет нормальный.
Все работает. На одной базе попробовали обновить без ТИИ, обновление не запустилось.
Еще раз автору респект!!!
35. Alex_E 2255 12.01.22 14:28 Сейчас в теме
(34) Рад помочь, хотя меня терзают смутные сомненья, что это я сделал)))
36. Sherochka65 13.01.22 00:11 Сейчас в теме
(35)Помогите пожалуйста. У меня та же проблема при обновлении. Возможности скачать обработку у меня нет. Ваша обработка мне помогла бы очень. Нужно сдавать отчетность, а обновления в базе нет. Горю как швед под Полтавой.
37. swi76 13.01.22 08:37 Сейчас в теме
Можно еще запустить обработку поиск дублей , затем удаление помеченных объектов, И все уже не ругалась программа, Мне помогло в ЗУП , ругалась что Вид доходов с кодом 2300 и 2012 уже есть ...
38. Alex_E 2255 13.01.22 08:52 Сейчас в теме
(37) см (32) и (33)
А можно запустить эту обработку перед обновлением и всё произойдёт быстрее даже с точки зрения махать мышкой - тут файл открыть выбрать обработку и нажать Исправить, а в Вашей транскрипции действий пользователь должен произвести намного больше))))) НО это так, к слову, просто уже много раз мне пытаются объяснить, что можно обойтись без этой обработки - отвечаю ещё раз - у меня всё это вылезло и решилось БЕЗ ЭТОЙ ОБРАБОТКИ, с помощью других средств, написал её потому, что народ попросил, кому не нать - проходим мимо))))
39. swi76 13.01.22 09:06 Сейчас в теме
(38)я понял эта обработка нужна тем кто уже начал обновлять и у них это случилось , а резерной копии нет , Вам большой плюс за обработку ...
40. user1037465 13.01.22 09:34 Сейчас в теме
Прошу помочь, пожалуйста. Вышла та же ошибка при обновлении, а резервной копии нет(
41. user1037465 13.01.22 10:39 Сейчас в теме
Обработка помогла)) Спасибо за помощь!
42. VAAngelov 277 13.01.22 14:23 Сейчас в теме
Все четко отработало на КА-2. Спасибо
43. Alex_E 2255 13.01.22 15:35 Сейчас в теме
(41)(42) А звездочку нажать?
Cat500; VAAngelov; +2 Ответить
44. VAAngelov 277 13.01.22 15:58 Сейчас в теме
(43)так я ж нажал) всегда нажимаю) толковым ребятам надо помогать)
45. Alex_E 2255 13.01.22 16:20 Сейчас в теме
(44) Полностью поддерживаю - толковый подход))))
Cat500; user1727219; VAAngelov; +3 Ответить
47. пользователь 13.01.22 17:12
Сообщение было скрыто модератором.
...
46. пользователь 13.01.22 16:42
Сообщение было скрыто модератором.
...
48. user1558996 14.01.22 00:05 Сейчас в теме
Прошу помощи. Та же ошибка при обновлении
49. nh76 14.01.22 01:23 Сейчас в теме
Обработка не помогла, но натолкнула на мысль. На скорую руку создал обработку по замене кода и отмене предопределенного для выбранного проблемного элемента, все обновилось. После уже обработкой поиск и удаление дублей почистил. Возможно кому то поможет.
50. user1558996 14.01.22 02:10 Сейчас в теме
(49)
отмене предопределенного для выбранного проблемного элемента
можно попробовать обработку?
51. user1558996 14.01.22 07:30 Сейчас в теме
обработка v1.6 помогла, спасибо большое
52. Cat500 14.01.22 11:49 Сейчас в теме
Спасибо большое автору обработки. Ставлю большой плюс.
53. zavsom 97 18.01.22 07:10 Сейчас в теме
А если ошибка 2013 , тогда поможет?
54. Alex_E 2255 18.01.22 07:59 Сейчас в теме
(53) Обработка не ищет какой то конкретный код в справочнике, а ищет и заменяет, потом удаляет дубли. Дублей может быть несколько (кстати, то, что Вы увидели код 2013, это не значит, что больше дублей нет, видел в нескольких базах было 2012 и 2300).

ЗЫ zavsom, тебя за что разбанили то?
55. ssvetusik 9 18.01.22 08:21 Сейчас в теме
56. DenisSDG 18.01.22 12:54 Сейчас в теме
Не удалось определить ""правильный"" элемент справочника! Исправление не прошло...

Вот такое сообщение выдает
57. Now 15 18.01.22 17:38 Сейчас в теме
Не помогла обработка..
Не удалось определить "правильный" элемент справочника! Исправление не прошло...

При обновлении на 3.0.106.101 ошибка такая:
Уже существует вид дохода ндфл с таким значением поля Код (2013)
{Справочник.ВидыДоходовНДФЛ.МодульМенеджера(552)}: Объект.Записать();
{(1)}:Справочники.ВидыДоходовНДФЛ.ПроставитьКод2021Года()
{ОбщийМодуль.ОбщегоНазначения.Модуль(5263)}: Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(6468)}: ОбщегоНазначения.ВыполнитьМетодКонфигурации(Обработчик.Процедура, ПараметрыОбработчика);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(1333)}: ВыполнитьОбработчикОбновления(Обработчик, ПараметрыОбработчика, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2102)}: ИтерацияОбновления.ВыполненныеОбработчики = ВыполнитьИтерациюОбновления(ИтерацияОбновления, Параметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(93)}: ВыполнитьДействияПриОбновленииИнформационнойБазы(ПараметрыОбновления, ДополнительныеПараметры);
{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(2407)}: Результат = ВыполнитьОбновлениеИнформационнойБазы(ПараметрыОбновления);
{(1)}:ОбновлениеИнформационнойБазыСлужебный.ВыполнитьОбновлениеИнформационнойБазыВФоне(Параметры[0],Параметры[1])
{ОбщийМодуль.ОбщегоНазначения.Модуль(5263)}: Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
{ОбщийМодуль.ДлительныеОперации.Модуль(1124)}: ОбщегоНазначения.ВыполнитьМетодКонфигурации(ИмяПроцедуры, ПараметрыВызова);
{ОбщийМодуль.ДлительныеОперации.Модуль(1114)}: ВызватьПроцедуру(ВсеПараметры.ИмяПроцедуры, ВсеПараметры.ПараметрыПроцедуры);

по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
Уже существует вид дохода ндфл с таким значением поля Код (2013)
58. Now 15 18.01.22 20:00 Сейчас в теме
Чтобы не держать народ без работы нарисовал простейшую обработку для своего случая (код 2013):
&НаКлиенте
Процедура ИзменитьКод(Команда)
	ИзменитьКодСервере("2013");
КонецПроцедуры

&НаСервере
Процедура ИзменитьКодСервере(КодДоходаНДФЛ)
	ИзменяемыйСсылка = Справочники.ВидыДоходовНДФЛ.НайтиПоКоду(КодДоходаНДФЛ);
	Если ИзменяемыйСсылка <> Справочники.ВидыДоходовНДФЛ.ПустаяСсылка() Тогда 
		Сообщить("Найден элемент "+ КодДоходаНДФЛ);
		ОбъектДанных = ИзменяемыйСсылка.ПолучитьОбъект();
		ОбъектДанных.ОбменДанными.Загрузка = Истина;
		ОбъектДанных.Код = "_" + Прав(КодДоходаНДФЛ,3);	
		ОбъектДанных.Записать();	
	КонецЕсли;
КонецПроцедуры
Показать


База заработала, сразу Поиск и замену дублей и изменить код с "_013" на "2013"
verniypro; Alex_E; +2 Ответить
59. lord_ascent 19.01.22 17:27 Сейчас в теме
так вот выдало
Прикрепленные файлы:
60. kokman 21.01.22 16:03 Сейчас в теме
Эта проблема решается ещё проще!

1. Запустить 1С /RunModeOrdinaryApplication
2. Открываем Операции/справочник Вид дохода НДФЛ
3. Кнопка Все действия-Восстановить начальные значения
4. Запустить обработку удаления
nporrep; alimuslim; +2 Ответить
62. crow1983 7 24.01.22 12:32 Сейчас в теме
(60) В этом случае дубль помечается на удаление. При этом висит табличка, что осталось 60 сек до закрытия 1С, т.к идет обновление. В управляемом режиме запустил обработку по замене значений. В обычном
2. Открываем Операции/справочник Вид дохода НДФЛ
3. Кнопка Все действия-Восстановить начальные значения
4. Запустить обработку удаления

Спасибо за подсказку.
Оставьте свое сообщение

См. также

Групповая установка даты выплаты в документах "Отпуск" и "Командировка" на заданную дату и перерасчет отобранных документов Промо

Обработка документов Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Обработка позволяет расчетчикам сократить время, затрачиваемое на расчет отпусков и командировок.

2 стартмани

15.02.2017    23547    90    ser6702    18    

Групповое создание документов "Начисление зарплаты сотрудникам организации" (аванс и зарплата) в УПП

Зарплата Обработка документов v8 УПП1 Россия БУ Абонемент ($m)

Создаем "Начисление зарплаты сотрудникам организации" (аванс и зарплата) с отбором по организациям нажатием пары кнопок.

1 стартмани

12.07.2021    4063    0    VAAngelov    7    

Начальная настройка программы в ЗУП. Включенные премии

Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Зашли в ЗУП, запустили обработку "Начальная настройка программы", а премий в ней нет?

1 стартмани

29.04.2021    5021    7    VAAngelov    6    

Личный кабинет сотрудника для 1С: ЗУП (1С + Vue.js + Node.js)

Зарплата WEB v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

WEB приложение "Личный кабинет сотрудника" + расширение 1С для тех, кто не хочет публиковать 1С в интернет.

1 стартмани

20.05.2020    12443    11    ShiningPhoenix    41    

Конвертация данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Промо

Внешние источники данных Зарплата v8 КА1 ЗУП2.5 УПП1 БГУ Россия БУ Госбюджет Абонемент ($m)

Перенос данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Переносит данные сотрудника, физического лица и начисления за произвольный период

1 стартмани

10.06.2014    41728    67    kns77    87    

Помощник подготовки данных для СЗВ-ТД

Зарплата Обработка документов Документооборот и делопроизводство v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

С 1 января 2020 г. начался переход на электронные трудовые книжки. Работодателям в 2020 г. предстоит выполнить ряд мероприятий для перехода на ЭТК, а также ежемесячно отчитываться в ПФР обо всех кадровых изменениях по форме СЗВ-ТД. В этой публикации размещена обработка, которая поможет быстро подготовить кадровые документы для заполнения СЗВ-ТД в программе 1С ЗУП 3.1, 1С ЗКГУ 3.1.

1 стартмани

23.01.2020    15149    115    Kaval88    62    

ЗУП 3.1.10 или когда пропадают элементы в отборах списком

Адаптация типовых решений Зарплата Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

ЗУП 3.1.10 значительно изменил функционал формы отчетов по сравнению с 3.1.9, 3.1.8 и т.д.. В отчетах в отборах с видом сравнения: В списке, В группе из списка - неприятно, но стали пропадать из списков не отмеченные флажком элементы. Данное расширение решает проблему, не изменяя типовой функционал.

1 стартмани

31.07.2019    14223    7    sapervodichka    6    

Подсистема справок (ЗУП 3.х)

Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Подсистема справок внешней печатной формой для 1C: Зарплата и Управление Персоналом, редакция 3.х.

1 стартмани

25.04.2019    18393    27    🅵🅾️🆇    17    

Выгрузка документов из ЗУП в БП (1С 8.2-8.3) Промо

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 БП2.0 ЗУП2.5 Абонемент ($m)

Обработка для выгрузки документов из конфигурации "Зарплата и управление персоналом" 8.2 в конфигурацию "Бухгалтерия предприятия" 8.2. Использует правила обмена. В обработке создан удобный интерфейс для гибкого формирования списка документов кадрового учета и начисления ЗП.

1 стартмани

18.12.2012    23598    139    d.zhukov    20    

Помощник перехода с КА 1.1 на ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата v8 КА1 ЗУП3.x Россия БУ НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Обработка предназначена для переноса данных из КА 1.1 в ЗУП 3.1.

3 стартмани

25.12.2018    38786    137    gudogu    40    

Расчет Тарификации и зарплаты в средних общеобразовательных школах для ЗКГУ - 3.1 (релиз 3.1.20.71)

Зарплата Зарплата Бюджетный учет v8 v8::СПР ЗКГУ3.0 Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Данная настройка конфигурации предназначена для расчета Тарификации педработников и расчета зарплаты в средних общеобразовательных учреждениях. Настройка сделана на базе Типовой конфигурации "Зарплата и кадры государственного учреждения" редакции 3.1.

2 стартмани

05.09.2018    40370    64    ivnik    24    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    39559    67    СергейКа    30    

Выгрузка из ЗУП 3.1 в БП 2.0 документов на выплату зарплаты, отражения в учете. (Отражение зарплаты в бухучете, ведомость на выплату в банк, в кассу, через раздатчика, перечислением)

Перенос данных из 1C8 в 1C8 Банковские операции Зарплата v8 БП2.0 ЗУП3.x БУ Абонемент ($m)

Позволит без труда выгрузить документы по отражению зарплаты и ведомости на выплату зарплаты из "Зарплата и Управление персоналом 3.1" в "Бухгалтерия предприятия 2.0"

3 стартмани

10.07.2018    21784    170    Redinternational    11    

Собственные нумераторы для ЗУП, ЗГУ (расширение)

Обработка документов Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ УУ Абонемент ($m)

Собственные нумераторы для «1С:Зарплата и управление персоналом, ред. 3», «1С:Зарплата и кадры государственного учреждения» (расширение). Любые виды документов, любое количество нумераторов. Сквозная нумерация кадровых приказов и не только.

1 стартмани

19.06.2018    22255    190    tomvlad    37    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    33550    21    notserioussam    2    

Выгрузка проводок из ЗУП 3.1 и загрузка в УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата Файловые протоколы обмена, FTP Зарплата v8 УПП1 ЗУП3.x Россия БУ Абонемент ($m)

Загрузка документов Отражение зарплаты в бухучете и Начисление оценочных обязательств из ЗУП 3.1 в УПП 1.3 с возможностью редактирования данных при загрузке.

1 стартмани

17.04.2018    16115    148    flyDrag    19    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов, справочников и планов видов расчета из конфигурации 1С ЗУП 2.5 в ЗУП 3.1.

3 стартмани

28.03.2018    38106    427    Cobranet123    67    

Настройка соответствий подразделений ЗУП 3.1 и БП 3.0

Перенос данных из 1C8 в 1C8 Зарплата Кадровый учет v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Синхронизация ЗУП 3 и БП 3.0: настройка соответствий подразделений при помощи внешней обработки.

8 стартмани

23.03.2018    37363    257    pas    36    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    56795    731    diso    224    

Перенос данных из конфигурации "Зарплата и управление персоналом" 3.1 в "Бухгалтерию предприятия" 2.0

Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Перенос данных по Ole Automation из ЗУП 3.1 в БП 2.0. Тестировался на релизах 2.0.66.46 и 3.1.2.483.

3 стартмани

15.03.2018    18398    20    roma_semenov79    0    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    50137    144    kostya_whiskas    25    

Рассылка расчетных листков. ЗУП 3.1

Email Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Рассылка расчетных листков. Простая. С подбором списком и журналом рассылки сообщений.

1 стартмани

02.02.2018    27181    299    bgalin    65    

Проверка данных для расчета среднего заработка, перенесенных в ЗУП 3.х из ЗУП 2.5

Обработка документов Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

При переходе с ЗУП 2.5 на ЗУП 3.х часто возникают ошибки в переносе данных для расчета среднего заработка, а именно, неправильно учитывается отработанное количество календарных дней. Для исправления этих ошибок и предназначено данное решение. Применимо для ЗУП 3.х.

3 стартмани

30.01.2018    29989    88    ni_cola    12    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    64311    36    mvv1975    7    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    40908    508    AntonH851    38    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    91799    1611    forseil    210    

Обмен данными между программами "1С: Бухгалтерия предприятия" редакция 2.0 и "1С: Зарплата и управление персоналом" редакция 3.1

Перенос данных из 1C8 в 1C8 Зарплата v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

В связи с отсутствием типовых правил обмена между конфигурациями БП 2.0 и ЗУП 3.1 (3.0) предлагается действующее решение в виде внешней обработки. Алгоритм построен на прямом подключении из базы БП к базе ЗУП. Для переноса данных используется COM-соединение с обработкой COM-объектов базы источника на стороне базы приемника.. Используется односторонний обмен - данные из ЗУП переносятся в БП.

1 стартмани

17.04.2017    32031    253    ivanovmi    38    

Правила обмена ЗУП 3.1(3.1.2.140) - УПП 1.3(1.3.88.2) - документа "Отражение зарплаты в регламентированном учете". Добавлено правило Отражения ERP20->БП30. ***Добавлено правило для ЗУП 3.1.5 и старше с использованием дополнительных реквизитов.

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 УПП1 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для производственных предприятий, где зарплата отдельной программой ЗУП 3.1 (для оперативного поддержания актуальности релиза), а управленческий и регламентированный учет ведется в УПП 1.3.

1 стартмани

24.03.2017    29536    230    bulas    51    

Поиск и исправление ошибок при заполнении 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0, УПП 1.3 версия от 28.08.2018

Регламентированный учет и отчетность Анализ учета Зарплата Зарплата v8 v8::БУ v8::СПР БП2.0 ЗУП2.5 УПП1 Россия БУ НДФЛ Абонемент ($m)

Помощь в поиске и исправлении ошибок при заполнении отчёта 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0 Просмотр всех записей регистров, имеющих отношение к учёту НДФЛ с детализаций до сотрудника и документа. Ручная корректировка основных регистров. Обновлённая версия от 02.07.2018г

3 стартмани

25.10.2016    45764    231    serge_msk    21    

Закрытие долгов. ЗКГУ 3.1, ЗУП 3.1

Зарплата Зарплата Закрытие периода v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ НДФЛ Абонемент ($m)

Обработка Закрытие долгов по регистрам накопления , конфигурация ЗКГУ 3.1 , ЗУП 3.1

1 стартмани

20.06.2016    34245    552    ccserg    75    

Перенос данных из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Абонемент ($m)

Обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.14.129 (8.3.15.1830).

2 стартмани

26.05.2016    53449    797    yojeeg    102    

Выгрузка реестра зарплаты в ГазПромБанк ЗУП 2.5 c ведущими нулями

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Корректно выгружает в текстовый формат поля, начинающиеся на НОЛЬ (Например, серии паспортов вида 0803)

5 стартмани

16.05.2016    39038    17    asher72    1    

Ещё один вариант свертки регистров учета НДФЛ (для ЗБУ/ЗКОУ/ЗКМУ ред. 1, ЗУП ред. 2.5)

Свертка базы Зарплата Зарплата v8 ЗУП2.5 ЗКБУ Россия НУ НДФЛ Абонемент ($m)

С появлением формы 6-НДФЛ вопрос правильного ведения исчисленного/удержанного/перечисленного НДФЛ встал не просто остро, а сверхостро! Поможем расчетчикам чем сможем...

1 стартмани

10.03.2016    40235    283    GlebHappy    50    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата Зарплата v8 v8::СПР ЗУП2.5 БУ НУ НДФЛ Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    44958    240    1kashak    23    

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5

Обработка документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    31896    71    pavel_pozdeev    4    

Резервы отпусков для УПП 1.3

Обработка документов Зарплата Зарплата v8 УПП1 Россия БУ Абонемент ($m)

Обработка для создания резерва отпусков в 1С: УПП 1.3

1 стартмани

14.12.2015    38216    53    sarun    5    

Удобная выгрузка зарплаты в формат CSV для Сбербанк Бизнес Онлайн (ЗУП 2.5)

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия БУ Абонемент ($m)

Самая удобная внешняя обработка для бухгалтера, не требует лишних действий! Выбрал документ и выгрузил в формате CSV для Сбербанк Бизнес Онлайн

10 стартмани

06.11.2015    47691    29    adinez    7    

Штатный перенос данных ЗУП 2.5 -> ЗУП 3.0 в режиме отладки

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Кадровый учет v8 ЗУП2.5 ЗУП3.x Абонемент ($m)

Штатный переход ЗУП 2.5 -> ЗУП 3.0 завершается при наличии ошибок в конвертации данных. Если механизм немного подправить, то можно обойти это ограничение. Назовем это режимом отладки. В итоге получим внешнюю обработку которая осуществит переход и просто сообщит о наличии ошибок конвертации данных.

1 стартмани

24.09.2015    28188    61    duhh    6    

Правила переноса зарплаты из ЗУП 3.0 в Бухгалтерию 2.0

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата v8 БП2.0 ЗУП3.x БУ Абонемент ($m)

Правила помогут Вам осуществить перегрузку начисления зарплаты из ЗУП 3.0 в Бухгалтерию 2.0

10 стартмани

11.09.2015    63075    276    leka99    63    

Расчет зарплаты в типовых конфигурациях 1С "Бухгалтерия предприятия 2.0 и 3.0"

Обработка документов Рабочее место Зарплата Зарплата v8 БП2.0 Россия БУ Абонемент ($m)

Как известно, расчет зарплаты в составе типовых конфигураций 1С Бухгалтерия предприятия 2.0 или 3.0 имеет крайне ограниченные возможности. Собственно расчета сумм как таковых не происходит – бухгалтер сам вычисляет и ставит готовую сумму начисления работнику по каждому виду расчета. В связи с этим была разработана Система «Зарплата», которая позволяет проводить расчеты сумм зарплаты сотрудникам организации в бухгалтерской программе 1С в типовых конфигурациях "Бухгалтерия предприятия 2.0" и "Бухгалтерия предприятия 3.0"

1 стартмани

26.01.2015    40423    183    Selivanov    26    

Выгрузка в банк из "Камин" заработной платы

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 1cv8.cf БУ Абонемент ($m)

Выгрузку можно делать для 2 банков ВТБ и Уралсиб, уралсиб выгружает 2 вида файлов

2 стартмани

23.10.2014    26515    0    hawk    1