Произвольная начальная страница через расширение (программно)

Публикация № 1107440

Разработка - Работа с интерфейсом

обработка начальная страница расширение программно

39
Установка своей формы произвольному пользователю на начальную страницу.

В копилку! (тестировалось и работает на платформе: 8.3.13.1513).

Об этом почему-то мало кто знает и не пользуется хотя есть официальная информация по крайней мере на 2-х страницах сайтов 1С.
Ссылки в конце статьи. 

Начальная страница – это стандартный раздел программы, содержащий часто используемые документы, отчеты, справочники и т.п. 
Как правило работа пользователя с программой всегда начинается с начальной страницы.

Предыстория:

Настраивать рабочий стол (начальную страницу) под себя, это не только изменять стандартные настройки заложенные в конфигурацию, но и желание использовать свои обработки, формы и т.д. на начальной странице. А иногда хочется, чтобы все что открывается стандартным способом, не открывалось, а открывалось только то, что тебе надо. Случайно наткнулся на статью на сайте 1С, как это возможно сделать, а с расширениями эта стало гораздо проще, плюсов как вы знаете множество!

Для того чтобы сей метод работал как надо, необходимо создать расширение или использовать существующее (статей на эту тему множество), добавить туда свою обработку или заимствовать нужные формы, которые вы желаете видеть на начальной странице и добавить обработчик, поигравшись с настройками.

Используя данный метод в зависимости от роли пользователя программно формировать его начальную страницу.  

Например:

Я использую в работе одну обработку, для меня она удобна. "Рабочий стол администратора": //mag.itwonline.ru/public/239307/

1) Добавил ее в расширение.

2. Из модуля сеанса, добавил в расширение процедуру "УстановкаПараметровСеанса", выбрал "После". Использовал код, с добавлением нужной роли.

Эта обработка открывается только у тех, у кого есть эта роль. Это пример. При добавлении процедуры в расширение, не забывайте использовать инструкции препроцессора. 

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
.....
#КонецЕсли
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область ОбработчикиСобытий

&После("УстановкаПараметровСеанса")
Процедура ВашПрефикс_УстановкаПараметровСеанса(ИменаПараметровСеанса) 
	
	// Загрузка обработки для администратора
    // Добавил конструкцию Если, чтобы открывалось для тех, у кого есть эта роль.
	Если ПользователиИнформационнойБазы.ТекущийПользователь().Роли.Содержит(Метаданные.Роли.Найти("Администрирование")) Тогда 
		НастройкиНачальнойСтраницы = Новый НастройкиНачальнойСтраницы;
		СоставФорм = Новый СоставФормНачальнойСтраницы;
		СоставФорм.ЛеваяКолонка.Добавить("Обработка.AdministratorsWorkspace.Форма.MainForm"); //описываем куда и какие формы использовать.
		НастройкиНачальнойСтраницы.УстановитьСоставФорм(СоставФорм);
        // Кладем объект настроек текущему пользователю.
		ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиНачальнойСтраницы",,НастройкиНачальнойСтраницы);
	КонецЕсли;

КонецПроцедуры

#КонецОбласти

#КонецЕсли

Итог: получаем свой рабочий стол (начальную страницу)! 

Ссылки на ресурсы:

1) Это работает при установке параметров сеанса, переопределяя уже существующие.

http://v8.1c.ru/o7/201402start/index.htm - информация 2014 года!

2) Пример работы с общим модулем "РаботаСИнтерфейсом"

https://its.1c.ru/db/pubv8devui/content/274/hdoc - более подробная информация сайта ИТС по подписке, если есть доступ. Это информация с книги "Разработка интерфейса прикладных решений на платформе "1С Предприятие8"".

Копия части главы:

 
39

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. akim2040 12 14.08.19 10:26 Сейчас в теме
Я не внимательно читал, или не пойму.
чем отличие от более удобного изменения рабочего стола вот этой обработкой? https://infostart.ru/public/556324/

каждый пользователь что хочет, то и может себе поставить на рабочий стол
2. nagaitseff 99 14.08.19 11:30 Сейчас в теме
(1) Конечно можно использовать и предложенную вами обработку, но у пользователя должно быть право "Интерактивное открытие внешних обработок", что например для больших организаций не очень и часто такое право отключают у пользователей или не дают вовсе.
Способ же который я предложил, не только не зависит от этого права, но и позволяет еще использовать дополнительные обработки, которых нет в базе на поддержке, это как пример.
3. akim2040 12 14.08.19 11:31 Сейчас в теме
4. AlexeyPapanov 333 15.08.19 14:32 Сейчас в теме
А что за начальная страница на скриншоте к публикации? Не из УНФ случайно? Так понравилось. Хочу найти.
6. nagaitseff 99 16.08.19 03:47 Сейчас в теме
(4) Добрый день, да это УНФ.
5. Yashazz 2539 16.08.19 00:03 Сейчас в теме
7. nagaitseff 99 16.08.19 03:50 Сейчас в теме
(5) Очень приятно, я Евгений.
9. Yashazz 2539 16.08.19 14:35 Сейчас в теме
Интересна позиция официальных представителей ИС насчёт копирования материалов с its.1c.ru. У автора есть такое разрешение, ведь правда же?
10. nagaitseff 99 16.08.19 14:58 Сейчас в теме
(9) Добрый день, на сайте 1с написано, копирование материала, только с указанием ссылки на материал (ресурс). Ссылки в статье указал.
11. WellMaster 99 21.08.19 16:08 Сейчас в теме
Вот если вы найдете способ убрать с начальной страницы заголовок "Начальная страница" и кнопки перехода - цены вам не будет! )
12. Trucker 6 22.08.19 09:08 Сейчас в теме
(11)
В режиме РабочееМесто мы скрываем все панели и область системных команд (главное меню и набор вспомогательных команд). Скрываем надпись Начальная страница, кнопки навигации Вперед/Назад, а также отключаем сочетания клавиш, которые используются в этих скрытых элементах интерфейса.

https://wonderland.v8.1c.ru/blog/novye-rezhimy-osnovnogo-okna/
Оставьте свое сообщение