Внешняя компонента для работы с драйвером "Атол v.10". 1С:8.3

Публикация № 1093799

Разработка - Разработка внешних компонент

Атол Atol KKT ККТ Драйвер Внешняя компонента JSON 10 Чек ККМ Продажа Касса

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.

Внешняя компонента, для работы с драйвером «Атол v.10», посредством JSON-заданий.
Описание JSON заданий, можно посмотреть на официальном сайте атол: http://integration.atol.ru/api/#json-tasks
Так как атоловский "WEB сервер", работал не стабильно и зависал через 2 часа работы, решил написать свою компоненту.
Компонента позволяет - проверить состояние смены, и оправить JSON-задание.
Для работы необходима библиотека "fptr10.dll" из поставки Атол "Драйвер контрольно-кассовой техники v.10" и VCREDIST 2015.
Рекомендую хранить библиотеку в общем макете для "32bit" и "64bit" систем.

Компонента ведет логи в "папка пользователя"\Documents\NativeAtolKKT.log

При вылетах и системных ошибках нужно смотреть логи.

Список JSON-заданий драйвера Атол v.10:

На данный момент компонента используется для пакетной печати чеков - на один электронный (без печати) чек, уходит 3 секунды.

Внимание перед установкой параметров соединения с ККТ необходимо выполнить "Атол.Инициализировать"


Свойства:

Атол.ПарольДоступа (Атол.AccessPassword)
Синтаксис:
Атол.ПарольДоступа = "30";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - пароль доступа.

 

Атол.ПарольПользователя (Атол.UserPassword)
Синтаксис:

Атол.ПарольПользователя = "30";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - пароль пользователя.

 

Атол.КаналОФД (Атол.OfdChannel)
Синтаксис:

Атол.КаналОФД = "0";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - канал обмена с ОФД.
Значения:
NONE = 0
USB = 1
PROTO = 2

 

Атол.КаналСвязи (Атол.Channel)
Синтаксис:
Атол.КаналСвязи = "2";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - способ связи с ККТ.
Значения:
COM = 0
USB = 1
TCPIP = 2
BLUETOOTH = 3

 

Атол.КомСкорость (Атол.BaudRate)
Синтаксис:

Атол.КаналСвязи = "9600";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - скорость работы ККТ по RS232.
Значения:
BR_1200 = 1200
BR_2400 = 2400
BR_4800 = 4800
BR_9600 = 9600
BR_19200 = 19200
BR_38400 = 38400
BR_57600 = 57600
BR_115200 = 115200
BR_230400 = 230400
BR_460800 = 460800
BR_921600 = 921600

 

Атол.КомБит (Атол.Bits)
Синтаксис:

Атол.КомБит = "8";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - количество бит в байте канала RS232.
Значения:
BITS_7 = 7
BITS_8 = 8

 

Атол.КомСтопБит (Атол.StopBits)
Синтаксис:

Атол.КомСтопБит = "1";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - количество стоп-битов канала RS232.
Значения:
SB_1 = 0
SB_1_5 = 1
SB_2 = 2

 

Атол.КомЧетность (Атол.Parity)
Синтаксис:

Атол.КомЧетность = "0";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - четность канала RS232.
Значения:
PARITY_NO - нет = 0
PARITY_ODD - четность = 1
PARITY_EVEN - нечетность = 2
PARITY_MARK - установлена = 3
PARITY_SPACE - сброшена = 4

 

Атол.КомПорт (Атол.ComFile)
Синтаксис:

Атол.КомПорт = "1";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - номер порта.
Значения: идентификатор порта. Для Windows - номер COM-порта (например, "15" или "COM15").
Для Linux - путь к TTY-файлу (например, "/dev/ttyS5" или "/dev/ttyACM0").


Атол.ЛинуксПутьКУСБ (Атол.UsbDevicePath)
Синтаксис:

Атол.ЛинуксПутьКУСБ = "auto";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - расположение USB-устройства в системе (только Linux).
Значения: расположение USB-устройства в системе (только Linux).
Если настройка не указана, имеет значение "auto" или пустое значение, то поиск и подключение к устройству будет проводиться по известным драйверу VendorID и ProductID.
На Windows подключение всегда ведется по VendorID и ProductID.


Атол.ИПАдрес (Атол.IPAddress)
Синтаксис:

Атол.ИПАдрес = "192.168.1.25";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - IP-адрес ККТ.
Значения: Может быть как ip-адресом, так и hostname-ом.

 

Атол.ИППорт (Атол.IPPort)
Синтаксис:

Атол.ИППорт = "5555";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - IP-порт ККТ.
Значения: 1-65535

 

Атол.МАКАдрес (Атол.MACAddress)
Синтаксис:

Атол.МАКАдрес = "FF:FF:FF:FF:FF:FF";
Описание:
Использование: чтение, запись.
Тип: Строка.
Устанавливает параметр - Bluetooth MAC-адрес ККТ.
Значения: Bluetooth MAC-адрес ККТ.
Устройство должно быть предварительно сопряжено с хостом средствами ОС.

 

Атол.Ошибка (Атол.GetError)
Синтаксис:

Сообщить(Атол.Ошибка);
Описание:
Использование: чтение.
Тип: Строка.
Возвращает последнюю ошибку компоненты.

 

Атол.КодОшибки (Атол.GetErrorCode)
Синтаксис:

Сообщить(Атол.КодОшибки);
Описание:
Использование: чтение.
Тип: Целое число.
Возвращает код ошибки, драйвера Атол. (используется как проверка на "ошибок нет" = 0)
Описание кодов, можно посмотреть в документации: http://integration.atol.ru/api/#f9886ca2bc

 

Атол.СостояниеСоединения (Атол.Opened)
Синтаксис:

Сообщить(Атол.СостояниеСоединения);
Описание:
Использование: чтение.
Тип: Булево.
Возвращает "истина" если соединение с ККТ установлено, иначе "ложь".


Атол.СостояниеСмены (Атол.Shift_State)
Синтаксис:

Сообщить(Атол.СостояниеСмены);
Описание:
Использование: чтение.
Тип: Целое число.
Возвращаемое значение:
Смена открыта = 0
Смена закрыта = 1
Смена истекла = 2

Функции:

Атол.Инициализировать (Атол.Initialize)
Синтаксис:

Атол.Инициализировать(<ПутьКбиблиотеке_fptr10.dll>);
Параметры:
<ПутьКбиблиотеке_fptr10.dll> - путь к библиотеке драйвера Атол 10, на диске.
Возвращаемое значение: булево, (истина - успех)
Описание:
Подключает библиотеку (fptr10.dll) драйвера атол.
Библиотеку нужно указвать той-же разрядности что и 1С.

 

Атол.Открыть (Атол.Open)
Синтаксис:

Атол.Открыть();
Возвращаемое значение: булево, (истина - успех)
Описание:
Открывает соединение с ККТ.

 

Атол.Закрыть (Атол.Close)
Синтаксис:

Атол.Закрыть();
Возвращаемое значение: булево, (истина - успех)
Описание:
Закрывает соединение с ККТ.

 

Атол.ОтправитьJSON (Атол.RequestJSON)
Синтаксис:

ОтветJSON = Атол.ОтправитьJSON(<JSONтекст>);
Параметры:
<JSONтекст> - текст с JSON структурой.
Возвращаемое значение: Строка (Текст с JSON структурой.) Описание смотри в документации: http://integration.atol.ru/api/#json-tasks
Описание:
Отправляет JSON-задание на ККТ.

 

************************************************

Пример реализации:

ОбщийМакет.АтолККТ - двоичные данные, "zip" архив внешней компоненты. 

ОбщийМакет.fptr10x64 - библиотека драйвера Атол 64 битная.

ОбщийМакет.fptr10 - библиотека драйвера Атол 32 битная.

Общий модуль: МодульККТ


Функция ПодключитьАтолКомпоненту() Экспорт 
	
	Попытка
		Если НЕ ПустаяСтрока(ПараметрыСеанса.АдресХранилищаАтолСоединение) Тогда
			Подключение = ПолучитьИзВременногоХранилища(ПараметрыСеанса.АдресХранилищаАтолСоединение).АтолККТ;
			Возврат Подключение;
		КонецЕсли;
	Исключение
		ПараметрыСеанса.АдресХранилищаАтолСоединение = "";
	КонецПопытки;	
	
	КомпУст=Ложь;
	Попытка
		КомпУст=ПодключитьВнешнююКомпоненту("ОбщийМакет.АтолККТ","NativeAtol",ТипВнешнейКомпоненты.Native);
	Исключение
		ПоказатьОповещениеПользователя("Произошла исключительная ошибка при подключении компоненты!",,ОписаниеОшибки(),БиблиотекаКартинок.Остановить);
	КонецПопытки;
	Если Не КомпУст Тогда
		ПоказатьОповещениеПользователя("Произошла ошибка при подключении компоненты!",,"",БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Попытка 
		СисИнфо = Новый СистемнаяИнформация;
		Если СисИнфо.ТипПлатформы = ТипПлатформы.Windows_x86 Тогда
			ПолучитьОбщийМакет("fptr10").Записать(КаталогВременныхФайлов()+"fptr10.dll");
		ИначеЕсли СисИнфо.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда
			ПолучитьОбщийМакет("fptr10x64").Записать(КаталогВременныхФайлов()+"fptr10.dll");
		КонецЕсли;
	Исключение
		ЗаписьЖурналаРегистрации("АтолККТ",УровеньЖурналаРегистрации.Ошибка,,ОписаниеОшибки());
		//Возврат Неопределено;
	КонецПопытки;
	
	АтолККТ = Новый("AddIn.NativeAtol.АтолККТ");
	АтолККТ.Инициализировать(КаталогВременныхФайлов()+"fptr10.dll");
	АтолККТ.КаналСвязи = "2"; 
	АтолККТ.ИПАдрес = СокрЛП(Константы.ИпАдресСервераККТ.Получить());
	АтолККТ.ИППорт = "5555";
	
	Попытка
		СтруктураАтолКомпонента = Новый Структура("АтолККТ",АтолККТ);
		АдресАтолККТ = ПоместитьВоВременноеХранилище(СтруктураАтолКомпонента,Новый УникальныйИдентификатор);
		ПараметрыСеанса.АдресХранилищаАтолСоединение = АдресАтолККТ;
		Возврат АтолККТ;
	Исключение
		ЗаписьЖурналаРегистрации("АтолККТ",УровеньЖурналаРегистрации.Ошибка,,ОписаниеОшибки());
		Возврат Неопределено;
	КонецПопытки;
	
КонецФункции

Функция СформироватьJSONЧек(Продажа,ТелоЧека) Экспорт  //Продажа(истина) - продажа, возврат продажи
	//ТелоЧека-структура с данными чека(Оператор;Итог;ЕмаилИлиТелефон,ИмяКлиента,ИННКлиента;СтрокиЧека-массив со структурами(Наименование,Цена,Количество,Сумма,НДС)) 
	
	Чек = Новый Структура;
	Позиции = Новый Массив;
	Оплаты = Новый Массив;
	
	Для Каждого ПозицияЧека Из ТелоЧека.СтрокиЧека Цикл 
		Позиция = Новый Структура;
		Позиция.Вставить("type","position");
		Позиция.Вставить("name",ПозицияЧека.Наименование);
		Позиция.Вставить("price",ПозицияЧека.Цена);
		Позиция.Вставить("quantity",ПозицияЧека.Количество);
		Позиция.Вставить("amount",ПозицияЧека.Сумма);
		Позиция.Вставить("department",1);
		Позиция.Вставить("paymentMethod","fullPayment");
		Позиция.Вставить("paymentObject","service");
		Позиция.Вставить("tax",Новый Структура("type",ПолучитьНалог(ПозицияЧека.НДС)));
		Позиции.Добавить(Позиция);
	КонецЦикла;
	
	Оплаты.Вставить(0,Новый Структура("type,sum","electronically",ТелоЧека.Итог));
	
	Чек.Вставить("type",?(Продажа = Истина,"sell","sellReturn"));
	Чек.Вставить("taxationType","osn");
	Чек.Вставить("electronically",Истина);
	Чек.Вставить("operator",Новый Структура("name",ТелоЧека.Оператор));
	Чек.Вставить("clientInfo",Новый Структура("emailOrPhone,name,vatin",ТелоЧека.ЕмаилИлиТелефон,ТелоЧека.ИмяКлиента,ТелоЧека.ИННКлиента));
	Чек.Вставить("items",Позиции);
	Чек.Вставить("payments",Оплаты);
	Чек.Вставить("total",ТелоЧека.Итог);

	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку();
	ЗаписатьJSON(ЗаписьJSON,Чек);
	ДанныеJson = ЗаписьJSON.Закрыть();
	
	Возврат ДанныеJson;
	
КонецФункции

Функция ПолучитьСтруктуруJSON(ОтветJson) Экспорт 
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(ОтветJson);
	СтруктураJson = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();
	
	
	fiscalParams = ЗначениеСвойстваJSON(СтруктураJson,"fiscalParams"); //чек
	shiftStatus = ЗначениеСвойстваJSON(СтруктураJson,"shiftStatus");   //состояние смены
	
	ОтветСтруктура = Новый Структура;
	Если НЕ fiscalParams = Неопределено Тогда 
		ОтветСтруктура.Вставить("ДатаВремяЧека",ПрочитатьДатуJSON(fiscalParams.fiscalDocumentDateTime,ФорматДатыJSON.ISO));
		ОтветСтруктура.Вставить("ФПДЧека",fiscalParams.fiscalDocumentSign);
		ОтветСтруктура.Вставить("РегНомерККТ",fiscalParams.registrationNumber);
		ОтветСтруктура.Вставить("НомерФДЧека",fiscalParams.fiscalDocumentNumber);
	КонецЕсли;	
	Если НЕ shiftStatus = Неопределено Тогда
		ОтветСтруктура.Вставить("СтатусСмены",shiftStatus.state);
		ОтветСтруктура.Вставить("СменаИстечет",ПрочитатьДатуJSON(shiftStatus.expiredTime,ФорматДатыJSON.ISO));
	КонецЕсли;
	
	Возврат ОтветСтруктура;
	
КонецФункции

Функция ОткрытьПроверитьСмену(ИмяОператора) Экспорт 
	
	АтолККТ = ПодключитьАтолКомпоненту();
	СостояниеСмены = АтолККТ.СостояниеСмены;
	Если АтолККТ.КодОшибки = 0 Тогда 
		Если СостояниеСмены = 0 Тогда //закрыта
			json="{""type"": ""openShift"",""electronically"":""true"",""operator"": {""name"": """+ИмяОператора+"""}}";
			ОтветJSON = АтолККТ.ОтправитьJSON(json);
			Если АтолККТ.КодОшибки = 0 Тогда 
				Возврат Истина;
				//Результат = ПолучитьСтруктуруJSON(ОтветJSON);
			Иначе 
				ПоказатьОповещениеПользователя("Ошибка открытия смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
			КонецЕсли;
		ИначеЕсли СостояниеСмены = 1 Тогда //открыта
			Возврат Истина;
		ИначеЕсли СостояниеСмены = 2 Тогда //просрочена
			ПоказатьОповещениеПользователя("Внимание!",,"Смена истекла",БиблиотекаКартинок.Остановить);
			Возврат Ложь;
		КонецЕсли;
	Иначе 
		ПоказатьОповещениеПользователя("Ошибка проверки состояния смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

Функция ЗакрытьСмену(ИмяОператора) Экспорт 
	
	АтолККТ = ПодключитьАтолКомпоненту();
	СостояниеСмены = АтолККТ.СостояниеСмены;
	Если АтолККТ.КодОшибки = 0 Тогда 
		Если НЕ СостояниеСмены = 0 Тогда 
			json="{""type"": ""closeShift"",""electronically"":""true"",""operator"": {""name"": """+ИмяОператора+"""}}";
			ОтветJSON = АтолККТ.ОтправитьJSON(json);
			Если АтолККТ.КодОшибки = 0 Тогда 
				Возврат Истина;
				//Результат = ПолучитьСтруктуруJSON(ОтветJSON);
			Иначе 
				ПоказатьОповещениеПользователя("Ошибка закрытия смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
			КонецЕсли;
		ИначеЕсли СостояниеСмены = 0 Тогда //закрыта
			Возврат Истина;
		КонецЕсли;
	Иначе 
		 ПоказатьОповещениеПользователя("Ошибка проверки состояния смены!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

Функция ПолучитьНалог(НДС) //НДС - текст
	
	Налог = "none"; //БезНДС
	Если НДС = Перечисления.СтавкиНДС.БезНДС Тогда 
		Налог = "none";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС18 Тогда 
		Налог = "vat18";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС20 Тогда 
		Налог = "vat20";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС0 Тогда 
		Налог = "vat0";
	ИначеЕсли НДС = Перечисления.СтавкиНДС.НДС10 Тогда 
		Налог = "vat10";
	КонецЕсли;
	Возврат Налог;
	
КонецФункции

Функция ЗначениеСвойстваJSON(ОбъектСвойства,Свойство)
	
	Если ОбъектСвойства = Неопределено Тогда 
		Возврат Неопределено;
	КонецЕсли;
	ВремЗначение = Неопределено;
	Если ОбъектСвойства.Свойство(Свойство,ВремЗначение) Тогда 
		Возврат ВремЗначение;
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции


Функция печати чека:

функция Чек()
	АтолККТ = МодульККТ.ПодключитьАтолКомпоненту();
	Если АтолККТ.Открыть() Тогда
		//ЕСЛИ СМЕНА ЗАКРЫТА ОТКРЫВАЕМ
		Если МодульККТ.ОткрытьПроверитьСмену(Объект.Оператор.Наименование) Тогда
			
			СтрокиЧека = Новый Массив;
			Позиция = Новый Структура("Наименование,Цена,Количество,Сумма,НДС","сапоги",154.12,2,308.24, Перечисления.СтавкиНДС.БезНДС);
			СтрокиЧека.Добавить(Позиция);
			
			ТелоЧека = Новый Структура;
			ТелоЧека.Вставить("Оператор","оператор1");
			ТелоЧека.Вставить("ЕмаилИлиТелефон","a@a.a");//если поле будет пустым, чек распечатается.
			ТелоЧека.Вставить("ИмяКлиента","Пупкин.П.П");
			ТелоЧека.Вставить("ИННКлиента","12121212121");
			ТелоЧека.Вставить("Итог",308.24);
			ТелоЧека.Вставить("СтрокиЧека",СтрокиЧека);
			//отправка чека
			//ТелоЧека-структура с данными чека(Оператор;Итог;ЕмаилИлиТелефон,ИмяКлиента,ИННКлиента;СтрокиЧека-массив со структурами(Наименование,Цена,Количество,Сумма,НДС)) 
			ОтветJSON = АтолККТ.ОтправитьJSON(МодульККТ.СформироватьJSONЧек(Продажа,ТелоЧека));
			Если АтолККТ.КодОшибки = 0 Тогда 
				//ошибок нет получаем результат
				Результат = МодульККТ.ПолучитьСтруктуруJSON(ОтветJSON);
				//обрабатываем результат
			Иначе 
				//АтолККТ.Ошибка;
				//АтолККТ.КодОшибки;
			КонецЕсли;
			
			Если НЕ АтолККТ.КодОшибки = 0 Тогда
				ПоказатьОповещениеПользователя("Ошибка чека, отправка прервана!",,АтолККТ.Ошибка,БиблиотекаКартинок.Остановить);
				Возврат Ложь;
			КонецЕсли;
		КонецЕсли;
		
		АтолККТ.Закрыть();
		Возврат Истина;
	Иначе
		ПоказатьПредупреждение(,АтолККТ.Ошибка,0,"Ошибка подключения к кассе!");
		Возврат Ложь;
	КонецЕсли;
конецфункции

 

Скачать файлы

Наименование Файл Версия Размер
1С8.3: Внешняя компонента, для работы с драйвером «Атол v.10»: Атол ККТ zip
.zip 203,40Kb
15.07.19
11
.zip 1 203,40Kb 11 Скачать
Библиотеки драйвера Атол ККТ 10 (32-64 бит) - можно скачать с сайта атол
.7z 1,34Mb
08.02.20
3
.7z 10 1,34Mb 3 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. alex_makhnov 07.02.20 17:35 Сейчас в теме
Все хорошо, но почему-то на ОтветJSON = Атол.ОтправитьJSON(<JSONтекст>); 1С вылетает.
При этом чек пробивается...
2. gortrex 58 08.02.20 22:20 Сейчас в теме
(1) Посмотрите логи компоненты, они находятся в папке документы: "папка пользователя"\Documents\NativeAtolKKT.log
Оставьте свое сообщение

См. также

Внешняя компонента для работы по Web-socket протоколу Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

5 стартмани

30.03.2018    21260    31    Ditron    66    

Быстрая печать этикеток (ZPL, EPL, TSPL, EZPL, GEPL, TSPL-EZ)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Качественная и быстрая печать на внутреннем языке принтеров этикеток.

4 стартмани

02.02.2020    3597    19    Johny_v    5    

Сканирование по TWAIN в 1С (обычные и управляемые формы)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пример, как можно в 1С проводить сканирование с помощью компоненты TWAIN.

3 стартмани

03.01.2020    3165    17    Diana.dedov.91    0    

Слипы вышли, а чек - нет!

Розничная торговля Расширения Кассовые операции v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Флаг устанавливающий Эквайринговый терминал как эмулятор для пробития чеков по карте.

1 стартмани

14.11.2019    7922    22    obmanOZ    28    

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    60898    183    ah7777777    480    

Маленькая и скромная мобильная внешняя компонента

Разработка внешних компонент v8 Абонемент ($m)

Изваять простенькую мобильную компоненту на 1С для android не так-то просто. Посему назло отдельным супостатам, не желающим делится исходниками, представляю весь свой скромный труд на публичный суд.

1 стартмани

21.10.2019    7392    4    ripreal1    25    

Native внешняя компонента для оповещения по UDP или TCP

Разработка внешних компонент v8 Абонемент ($m)

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    6721    13    vdv2701    26    

Внешняя компонента Sundries: несколько полезных системных функций

Разработка внешних компонент v8 Абонемент ($m)

Звук, пауза, буфер обмена, раскладки клавиатуры и т.д.

3 стартмани

30.08.2019    3983    3    sivin-alexey    10    

Печать покупателя в чеке ККМ с 01.07.2019

ККМ Кассовые операции Печатные формы документов Кассовые операции v8 ERP2 БУ Абонемент ($m)

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    20084    20    sapervodichka    14    

Эмулятор ККМ по стандарту ФФД 1.1

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v8 Розница УТ11 Россия Абонемент ($m)

Эмулятор драйвера ККМ по стандарту ФФД 1.1 предназначен для использования всех возможностей программы, при отсутствии физической кассы. Подойдет как программистам при разработке интерфейса РМК, например, так и пользователям для тестирования возможностей программы.

1 стартмани

30.12.2018    16769    119    Matveymc    21    

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 УТ10 УПП1 Абонемент ($m)

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    47099    64    Johny_v    42    

РКО укороченный (1/2 А4) для БП 2.0, БП 3.0 Промо

Печатные формы документов Кассовые операции Кассовые операции v8 v8::БУ БП2.0 БП3.0 Россия БУ Абонемент ($m)

Расходный-кассовый ордер укороченный (на половину А4) для 1С: Бухгалтерия предприятия 2.0. и 3.0

1 стартмани

23.07.2012    16406    6    signum2009    10    

АТОЛ ВЕБ-СЕРВИС 54ФЗ. Для работы с онлайн-кассами АТОЛ через веб-сервер (Ревизия 3002)

ККМ Кассовые операции Кассовые операции v8 КА1 УТ10 УПП1 БГУ БАУ 1С:CRM Россия Абонемент ($m)

Хотите ускорить печать чеков, или печатать с разных рабочих мест на один фискальный регистратор? В этом вам поможет, настроенный веб-сервис от фирмы АТОЛ, а данная разработка позволит интегрировать его с вашей программой 1С.

4 стартмани

03.12.2018    30061    196    karpik666    253    

WebSocket Клиент / Сервер. Внешний компонент

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Реализация протокола WebSocket. Клиентская часть для взаимодействия с внешними сервисами. Серверная часть для организации собственного сервера, принимающего клиентские соединения в многопоточном режиме. Возможно взаимодействие RabbitMQ Slack Asterisk и другие

1 стартмани

16.11.2018    11490    60    nomadon    48    

Внешняя компонента для выполнения регулярных выражений

Разработка внешних компонент v8 Абонемент ($m)

Внешняя Native API компонента для выполнения регулярных выражений на платформе 1С:Предприятие 8. Написана на C++. Используется движок boost::regex (v 1.69, v 1.68 - для Android). Версия синтаксиса Perl Compatible Regular Expressions.

1 стартмани

12.11.2018    10151    25    KAV2    62    

TextRadar - нечеткий поиск в тексте Промо

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    13880    15    TSSV    14    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    15656    28    echo77    38    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    19754    175    RSConsulting    15    

Эмулятор эквайрингового терминала

ККМ Кассовые операции Кассовые операции v8 Розница Россия УУ Абонемент ($m)

Эмулятор эквайрингового терминала для тестирования взаимодействий с разрабатываемыми или типовыми решениями.

1 стартмани

26.07.2018    15663    150    trigor    16    

Распознавание лиц (off-line). Демонстрационная база.

Разработка внешних компонент v8 Абонемент ($m)

Распознавание лиц входит в нашу жизнь стремительными темпами, бизнес стремится за событиями. В публикации находится описание и пример использования нейросетей для распознавания лиц.

1 стартмани

17.07.2018    14146    70    nomadon    45    

Внешняя компонента для ping'а

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Внешняя компонента для выполнения ping'а из 1С:Предприятия 8.

1 стартмани

04.07.2018    9253    5    frkbvfnjh    24    

JVM Native API плагин - для запуска в 1С плагинов написанных на Java

Разработка внешних компонент v8 Абонемент ($m)

Запускаем виртуальную машину Java в 1С. Собрана внешняя компонента которая позволяет запускать виртуальную машину java в среде 1С. Позволяет как передавать параметры в java - так и получать уведомление через externalevent. Предпосылкой создания являлся тот факт, что есть много готового функционала которого не хватает в 1С. Язык сpp - довольно сложен для быстрой разработки, и теперь возможно использовать готовые сборки java классов (так называемые jar-файлы) для использования в 1С.

1 стартмани

20.06.2018    9657    24    minimajack    67    

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера Промо

Кассовые операции ККМ Кассовые операции v8 Розница Абонемент ($m)

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    15708    13    valerasv    7    

Tool1CD: отрежем донорскую почку

Сервисные утилиты Разработка внешних компонент v8 Розница Абонемент ($m)

Ваша база мертва? Что ж, кое-что в ней ещё теплится.

1 стартмани

15.05.2018    17150    23    baton_pk    13    

Внешняя компонента Native для создания штрих кода (GS1 DataBar Expanded, GS1 DataBar Expanded Stacked и другие)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

В связи с внедрением ГИС Меркурий потребовалось внешняя компонента, которая создает штрихкод и отдает 1С. ВК создана на основе библиотеки zint www.sourceforge.net/projects/zint.

1 стартмани

27.04.2018    15472    190    artmaks1988    86    

Настройка и подключение кассы АТОЛ в 1С 8.3 ффд 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница БП3.0 УТ11 Россия Абонемент ($m)

Инструкция для подключения кассы по новому протоколу ффд 1.05.

1 стартмани

14.04.2018    130188    29    ZIGER666    156    

Использование сборок .NET в 1С 7.x b 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    77898    229    Serginio    69    

Выбор цены в РМК для УТ 11.3 и УТ 11.4 (расширение)

Рабочее место Кассовые операции Розничная торговля Кассовые операции Розничная торговля Ценообразование, анализ цен v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Расширение для УТ 11.3 и УТ 11.4, разрешает в рабочем месте кассира выбор вида цены или установку произвольной цены на каждую позицию.

1 стартмани

29.12.2017    24501    116    kassbar    78    

Чтение отчета ОФД (ПлатформаОФД/СБИС Тензор) + получение состава кассового чека

Внешние источники данных Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Чтение отчетов оператора ПлатформаОФД/СБИС Тензор с возможностью получения детализации по кассовым чекам для Управление торговлей 10.3.Х.ХХХ.

1 стартмани

12.12.2017    14531    15    independ    9    

Загрузка кассовых чеков с сервера ФНС. Расширение для 1С: Деньги

WEB Кассовые операции Кассовые операции v8 1cv8.cf Домашние учет и финансы Россия УУ Абонемент ($m)

Для тех, кто ведет домашние финансы в 1С:Деньги. Расширение поможет сократить время на ввод данных о расходах, вместо набивания данных руками, данные чека (сумму и товары) можно загрузить из электронного чека, который хранится на сервере ФНС.

1 стартмани

17.11.2017    18618    63    Bazil    49    

Пробитие чеков через ККМ в офисе (для курьеров) Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ Розница УТ11 Россия БУ Абонемент ($m)

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    27405    11    Kutuzov    12    

Подсветка синтаксиса 1С в текстовом редакторе VIM

Инструментарий разработчика Разработка внешних компонент v8 Россия Абонемент ($m)

Пакет, добавляющий поддержку синтаксиса языка 1С:Предприятие 8 в текстовом редакторе VIM

1 стартмани

25.09.2017    15752    3    TIS_08    27    

ККТ-ОНЛАЙН 54-ФЗ. Эмулятор ККТ с поддержкой ФФД 1.1. Обычные формы

Фискальный регистратор Кассовые операции Кассовые операции v8 УТ10 УПП1 Абонемент ($m)

Обработка обслуживания торгового оборудования для конфигураций на обычных формах

1 стартмани

04.09.2017    51894    378    Johny_v    35    

Tool1CD Beta в деле Промо

Разработка внешних компонент v8 Абонемент ($m)

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    22612    28    baton_pk    26    

Эмулятор ККТ с передачей данных для УПП 1.3.92+, КА 1.1.87+, УТ 10.3.43+

ККМ Кассовые операции Кассовые операции v8 КА1 УПП1 Абонемент ($m)

Простейший эмулятор обработки обслуживания ККТ с передачей данных.

1 стартмани

28.07.2017    35823    262    Brawler    50    

Обновление Бухгалтерии 2.0 для работы с 54-ФЗ Онлайн кассы

Кассовые операции ККМ SMS рассылки Email Кассовые операции v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Типовая конфигурация БП 2.0 не поддерживает работу с онлайн кассами. Это обновление конфигурации БП 2.0 позволяет подключить онлайн кассы, печатать чеки, отправлять их по email или SMS.

1 стартмани

08.06.2017    31944    286    Zorkon    123    

Native Api компонента для чтения и записи в COM-порт

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Позволяет отправить данные в COM-порт и получить ответ.

1 стартмани

30.05.2017    10070    77    Zahary    7    

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ Промо

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

2 стартмани

09.07.2017    39532    159    bob_    56    

Опыт интеграции ФР Штрих-М с 1С

Фискальный регистратор Кассовые операции Кассовые операции v8 1cv8.cf Россия БУ Абонемент ($m)

Надвигается 1 июля и всем срочно нужны ККМ-онлайн. Публикую свой опыт быстрого и простого решения на базе фискального регистратора Штрих-М для обычных форм.

1 стартмани

01.05.2017    44932    22    Yashazz    79    

ФЗ-54. Печать кассового чека на основании «Реализация товаров и услуг» + автоматическое создание «Приходного кассового ордера». Для ККМ онлайн. УТ 10.3 и УТ 11.1(и выше)

Печатные формы документов Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ10 УТ11 Россия БУ Абонемент ($m)

Для организаций, принимающих от контрагентов оплату наличными, и перешедших на ККМ-онлайн, согласно ФЗ-54 необходимо печатать кассовый чек с детализацией. Обработка позволяет печатать чек ККМ непосредственно из документа «Реализация товаров и услуг».

5 стартмани

27.03.2017    43955    227    Vagner_Hate    219    

1С+Классы. Версия-0

Разработка внешних компонент Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Разработано ООП-расширение языка 1С, включающее (но не ограничивающееся): Классы как абстрактные типы данных с элементами «переменная», «свойство», «функция», «процедура»; Интерфейсы как абстрактные классы без элементов состояния («переменная») и без привязки к реализации методов (свойств, процедур, функций) при определении; Имплементация (реализация) интерфейсов классами; - одиночное открытое наследование; Области видимости «внутренняя» (private), «экспорт» (public), «защищенная» (protected); Статические элементы классов (общие для всех экземпляров класса); Замещение (переопределение реализации) методов при наследовании – «виртуальные методы, свойства»; Сокрытие (затенение) обычных (не замещаемых) элементов при наследовании; Перегрузка процедур и функций по количеству и типам данных аргументов; Конструкторы класса; Деструктор класса; Слабые ссылки; Делегаты.

1 стартмани

28.10.2016    18959    1    IntelInside    68    

Простая печать чеков в соответствии с 54-ФЗ. Промо

Кассовые операции Фискальный регистратор Кассовые операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Простая программа для печати чеков на фискальных регистраторах через драйвер компании Штрих-М. Соответствует 54-ФЗ. Подходит для интернет-магазинов.

3 стартмани

07.07.2017    27019    25    Rik30    14    

"Внешнее событие" и мобильная платформа 1С

Разработка внешних компонент Мобильная разработка v8 Абонемент ($m)

Внешние компоненты в Android для Мобильной Платформы 1С или как вызвать внешнее событие, когда его нет.

1 стартмани

09.09.2016    34717    84    dewersia    50    

Организация файлового хранилища на базе MS SQL Server с доступом из 1С

Разработка внешних компонент Сервисные утилиты v8 Абонемент ($m)

Пример реализации хранения файлов в базе MS SQL Server с использованием различных технологий. Подробно рассмотрен потоковый доступ к файлам с использованием технологии FileStream.

1 стартмани

27.07.2016    22682    41    tohandr    37    

Внешняя компонента Native API для построения графов (на основе GraphViz)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Данная публикация представляет собой внешнюю компоненту «GraphViz NAPIC», выполненную по технологии native API, предоставляющую методы библиотеки GraphViz для построения графа по его описанию в текстовом формате на языке dot. Приложена обработка с примером вызова компоненты ОФ+УФ.

1 стартмани

12.04.2016    16905    24    Synoecium    19    

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол Промо

Кассовые операции Оптовая торговля Розничная торговля ККМ Кассовые операции Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    49725    127    Atom74    69    

QR-код 2 в 1 (обычная и управляемая форма)

Инструментарий разработчика Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Вам нужно интегрировать 1С и QR-коды? Нет ничего проще, будем использовать внешнюю компоненту!

1 стартмани

05.04.2016    29626    114    Xershi    40    

Внешняя компонента для сжатия/распаковки файлов, двоичных данных и строк по алгоритму Zlib, Deflate и GZip

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя компонента для сжатия/распаковки файлов, двоичных данных и строк по алгоритму Zlib, Deflate и GZip.

1 стартмани

15.03.2016    29699    123    frkbvfnjh    99    

Проект внешней компоненты для 1С:8 (сделай сам)

Разработка внешних компонент v8 Абонемент ($m)

Как их делают? Как регистрируют? С чего начать? Где взять стартовый проект? Вопросов вообще много можно задать, но лучше один раз увидеть!

10 стартмани

11.03.2016    13773    0    ture    36    

Снимок экрана для 1С

Универсальные обработки Разработка внешних компонент v8 1cv8.cf Россия Абонемент ($m)

Довольно часто люди сталкиваются с необходимостью сделать снимок экрана. Если вы или ваши сотрудники основную часть времени проводят в 1С и у вас есть необходимость прикреплять графические файлы, то эта компонента для вас.

1 стартмани

08.02.2016    25279    32    linkforget    11